Skip to main content
Share / Export

Implementation Balance - SL Subcontracts

Getting Started​

If you have open subcontracts at the time of conversion be sure to import these records to reflect accurate committed costs and ensure that future subcontract invoices are applied correctly against those commitments.

Template Info​

  • Required Source Data Header Table
  • Vendor #
  • Subcontract #
  • Job #
  • Description
  • Contract Date
  • Line Table
  • Subcontract #
  • SL Item #
  • Job #
  • Phase #
  • Cost Type #
  • Description
  • Unit of Measure
  • Original Units
  • Original Unit Cost
  • Original Cost
  • Retainage %
  • Optional Source Data N/A
  • Additional Tips The Subcontract column is used to link the Header and Line records together for each invoice, so make sure the numbers are unique and assigned appropriately.
  • Make sure to include all Subcontract Items in this import—even those created from subcontract change orders with $0 original amounts. These SL Items are required for the subcontract change order import.
  • Basic Steps Download TAD Template
  • Copy the Source Data
  • Import the Records
  • Post Open Batch
  • Validate Imported Data

Download TAD Template​

Open your source data file in Excel.

Download TAD Template screenshot

Click the Templates button on the left side of the ribbon.

Download TAD Template screenshot

If you've signed into TAD before, then you should receive the message below. Click Yes.

If you have not signed into TAD before, follow the Get Connected instructions.

Download TAD Template screenshot

Select the Implementation Balance – SL Subcontracts template.

Click the Download Selected button.

Download TAD Template screenshot

This template includes multiple tables, so make sure to check the Skip Remaining Parameter Entry box and click the Download button to download them all at once.

Download TAD Template screenshot

You’ll see multiple worksheets, as shown below.

The SL Subcontract Header and SL Subcontract Items sheets are used to import the subcontracts.

Download TAD Template screenshot

Copy the Source Data​

Copy and paste the header source data into the SL Subcontract Header sheet. If your source data layout matches the example above, this will be a single copy and paste since the SL Subcontract Header columns are already in the same order.

Copy the Source Data screenshot

Copy and paste the line source data into the SL Subcontract Items sheet. If your source data layout matches the example above, this will be a single copy and paste since the SL Subcontract Items columns are already in the same order.

Copy the Source Data screenshot

Import the Records​

Go to the SL Subcontract Header worksheet.

Click the submenu of the Format Table button on the ribbon and choose the Regenerate Excel Formulas button. This will apply formulas to multiple columns.

Import the Records screenshot

The Mth column defaults to the current month. Update this value if you're loading balances as of the prior month.

Import the Records screenshot

Click the Format Table button to format the data you copied and to apply missing default values.

Import the Records screenshot

The Result column will show Formatted for every record. You will see the default Company number applied.

Import the Records screenshot

Go to the SL Subcontract Items worksheet.

Click the submenu of the Format Table button on the ribbon and choose the Regenerate Excel Formulas button. This will apply formulas to multiple columns.

Import the Records screenshot

The Mth column defaults to the current month. Update this value if you're loading balances as of the prior month.

The Mth value should match the Mth value on the SL Subcontract Header worksheet.

Import the Records screenshot

Click the Format Table button to format the data you copied and to apply missing default values.

Import the Records screenshot

The Result column will show Formatted for every record. You will see the default Company number applied.

Import the Records screenshot

Go to the SL Subcontract Header worksheet.

Click the Get Batch # button to assign the next batch number to both the Header and Lines worksheets.

Import the Records screenshot

The Result column will show Batch #XX Assigned for every record.

Click the Validate Import button.

Import the Records screenshot

The Result column will show Validated for every record. If this says Failure, then the ErrorMsg column will provide the error.

Click the Execute Import button.

Import the Records screenshot

The Result column will show Imported for every record.

Import the Records screenshot

Go to the SL Subcontract Items worksheet.

The Result column will show Batch #XX Assigned for every record since that was the last action on the worksheet.

Click the Validate Import button.

Import the Records screenshot

The Result column will show Validated for every record. If this says Failure, then the ErrorMsg column will provide the error.

Click the Execute Import button.

Import the Records screenshot

The Result column will show Imported for every record.

That completes all steps needed in TAD. You can now open the SL Subcontract Entry batch in Vista to validate and post.

Import the Records screenshot

Post Open Batch​

There’s no interfacing that needs to be turned off for subcontracts.

Open the batch in SL Subcontract Entry.

With the batch open, go to File → Process Batch, then click the Validate button followed by the Post button.

Validate Imported Data​

You can validate the Subcontract Amounts by running the SL Subcontracts by Job report in Vista.

Enter your Company and the Through Month for the month that you just imported.

Make all other parameters look like the image below.

Validate Imported Data screenshot

Verify the Grant Total for the Current Contract total at the end of the report matches the transactions that you imported.

Validate Imported Data screenshot